Key tips to get you started

What to do when you
cannot figure out how to
use Q

Data files and file
management

When you analyze data in
Q you are always using
two files:

e Project file (.Q): this
contains all the work
you have done in Q.

» Data file (e.g.,.sav): this
contains your survey
data; Q does not
change the raw data.

o A Q Pack (.QPack) is
an archive of your
Project and your Data

Start a new project with your
data

Modify the table

Duplicate the table

Manipulate the table

Cheat Sheet

1. File > Data Sets P> Add to Project P From File

2. Select Automatically detect data file structure

3. (Optional) Choose from among Advanced options

In the Outputs tab choose the questions you want to show in the blue and brown
question menus

Country ©| sUMMARY v

Push the Duplicate table button in between the blue and brown drop down menus to
make new tables

I:% Duplicate

o Drag-drop categories and columns to move them and merge them
o Right-click to bring up menu of options (dependant on where you click)
o Highlight multiple categories with Shift or Ctrl, and then right-click

Right-click on whatever it is you are trying to change

Type into Search

Get help interpreting a table

Read the wiki
Do some training modules
Contact support

Start a new project

Starting using a QPack

Opening a project

Share projects

Update the data in a project
Merge different projects
Merge data files

Stack data

Panel data (e.g., occasion-
based data)

@ Search features and data

Help P> Interpret This Table

Help » Q Wiki (Online Reference Manual)
Help P> Online Training
support@gq-researchsoftware.com

. File > Data Sets » Add to Project » From File

. Select Automatically detect data file structure

. (Optional) Choose from among Advanced options

. Double-click on the QPack or File > Open P Existing Project
. File » Save

. Read any messages carefully (as you may destroy work)

WNhE wN

File » Open P> Existing Project or Recent Projects

File P> Share This sends the project and data files (as a Q Pack)

File > Data Sets P> Update

Open two copies of Q and drag and drop tables and variables from one project to another
Tools P> Merge Data Files

Tools P Stack SPSS Data File

1. Stack the data (if necessary)
2. File p> Data Sets P> Add to Project P From File
3. File » Data Sets P> Edit Relationships
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What to do when the data
looks wrong

Tables and plots

Note that the one of the
main ways of modifying a
table is to change the data
in the table, and when this is
done all other tables using
the same data will also
change (see

)

Weights and filters

Weights and filters can be
applied to the entire project
or to selected tables and
plots.

Visualizations

Contact the person that set up the project (if you did not do it yourself)

Check the base
Check n and base n

Check statistical testing

Check that the Question Type
setting makes sense on the
Variables and Questions tab

Check that the Filter is correct

Check that the Weight is
appropriate

Check that the correct rules
are applied and, try and
remove the rules

Hide or unhide variables

Check if empty rows/columns
are are hidden

Review the Value Attributes

Review how a variable has
been constructed

Contact support

View additional statistics

Duplicate a table

Changing the data

Create plots in Q

Customizing the look and feel
of tables

Lock the dropdowns used to
select data on a table

Create folders
Create lots of tables

Simultaneously change lots of
tables/plots

Applying filters and weights

Creating a weight

Allowing variables to be
selectable as weights and
filters

Creating simple filters

Creating filters from a table

Creating complicated filters
(eg: filters involving more than
2 variables, with OR, NOT and
AND statements)

Convert a table into a plot

Interactive and Advanced
Visualizations

base n = 0; total n = 13; 13 missing; 88% filtered out;
Statistics — Cells > n or Base n
Edit P Project/Table Options P> Statistical Assumptions

Show significance: Compare columns <
Either go to the Variables and Questions tab and find the data, or, press = to the
right of the relevant dropdown menu

Filter; Q8. One or more message not recalled

Eg,

Weight: None
E.g.,

If a Rule has been applied, a pink Rules tab will appear at the bottom of the table.
Control when applied using the Apply dropdowns

Table |Rules
On the Variables and Questions tab, press
Check to see if @ is depressed (this hides empty rows and columns)

Right-click on a row or column heading and select Values

Go to the Variables and Questions tab
Find the variable
Right-click: Edit Variable

File > Share P Send to Support (encrypted) & indicate which table and which cells in
the table look wrong and why

Right-click: Statistics — Cells/Right/Below »

Push the Duplicate table button in between the blue and brown drop down menus to
make new tables

l:ﬂi Duplicate

Choose the questions you want to show in the blue and brown question menus

Country v || SUMMARY v

Select from Show Data As (top middle of the screen)
Edit » Project Options P Customize and Table Styles

Right-click on table(s) in the Report and select Lock

Right-click on a table in the Report and Add group

Create P> Tables P> Banner Tables (this also automatically creates banners & flattens
data — see Manipulating Data)

Select them all at the same time and then modify as normal (e.g., apply filters, right-click
and Statistics — Cells)

In the Outputs tab highlight a table/chart in the report tree and then select from the
Filter or Weight menus. If applied, the filter/weight will be indicated in green.

Filter:

v| AND |Total sample|v| ¥ Weight| None hd

Create P> Variables and Questions P> Variable(s) P Weight
In the Variables and Questions tab, press F| W)

Automate P> Browse Online Library P Filtering P> Create Filters from Selected Data

Create a table, select the relevant cells and press §f

Create P> Variables and Questions P> Variable(s) P> Binary — Complicated Filter

1. Select a Table.
2. Choose an option from the Show Data As menu.

Show Data as: Table -

1. Create P> Charts P> Visualizations P> ...

2. Select the new R object in the Report Tree.
3. On the right hand-side in the Object Inspector, link it to a table or variables

Table [ -]
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Viewing raw data

Exporting

Any chart templates that you
create in Excel, PowerPoint
and Word, are available in
the Format dropdown that
appears when exporting. See
also

Manipulating data

There are lots of tools for
manipulating data. These
are only some of the more

commonly-used basic tools.

Automation in Q

Q brings efficiencies to your
quantitative workflow in many
ways.

For more information, search
the Q wiki and blogs for
‘Automatic’.

Seeing the raw data for a
question

Seeing raw data for lots of
variables in Excel

Seeing all the raw data in Q

Export to PDF

Export to Excel, PowerPoint and
Word

Automatically update Office
exports

Setting default chart types for
Office

Merging
Creating NETs

Sorting/Re-ordering
categories

Removing a category and
rebasing

Removing a category without
rebasing

Switch between % and
averages as main statistics
on a table

Creating a 2" version of a
question

Banding numeric variables

Recoding (changing Value
Attributes)

Create a banner

Create a new variable

Recoding into a different
variable

Standard mathematical
functions

Creating a binary variable

Using Rules [

Using QScripts

Updating your analysis

Automatic Updating of
PowerPoint

Automatic Updating of R

4. Click (hint: you can set Calculate to ‘automatic’ so it automatically updates if
you change the input table/variables)

In the Outputs tab Brown dropdown menu: RAW DATA

1. Select the variables in the Variables and Questions tab
2.Right-click: Export variables to Excel

3.In Excel: VIEW P> Freeze Panes P Freeze Top Row
4.In Excel: DATA W Filter

All the raw data is viewable on the Data tab. You can sort columns, show filters and re-
order the columns (this is done on the Variable and Questions tab)

File » Export P To PDF

(] (2] (w]

Ensure the Office document is open and export the relevant tables/charts again. If Q can
detect them as being already exported to the document, it will give you the option to
Update. See the Q wiki for more details on automatic updating.

1.Create Chart Templates using Excel, Word or PowerPoint
2.Edit > User Options » Export Chart Defaults

In the Outputs tab: Drag and drop, or, right-click: Merge

In the Outputs tab: Right-click: Create NET

In the Outputs tab:

e Drag and drop

e Right-click: Sort By

e See Using Rules on how to automate the sorting of categories on a table
In the Outputs tab:

o Right-click: Remove (only for mutually exclusive options)

o Filtering: Create a NET and right-click on it: Create filter

In the Outputs tab: Right-click: Hide

In the Outputs tab:

1. Right-click on the row or column headers on the table

2.Select the question (its name will appear near the bottom of the menu)
3.Select Restructure data and the appropriate option

In the Outputs tab: Right-click on table row/column heading: Duplicate Question

1. See Creating a 2nd version of a question above

2. See Switch between % and averages as main statistics on a table above

3. Merge the rows together according to the desired bands — See Merging above

In the Outputs tab: Right-click on table row/column heading, select Values and change the

numbers in the Value column

In the Outputs tab:

1.Create a new table

2.Create P> Banner P> Drag and Drop

e Variables & Questions tab: Create P> Variables and Questions P> Variable(s) P
JavaScript Formula P Numeric

o Search the Q Wiki for “JavaScript variables” to see examples of basic code

In the Variables & Questions tab:

1. Right-click: Copy and Paste Variable(s) » Exact copy

2. Modify the variable as per your needs

In the Variables & Questions tab: Insert Ready-Made Formula(s) P Mathematical

Functions (by Case)

Follow the steps for creating filters in Weights and Filters

» Example: Automate P> Online Library P> Sorting and Reordering P> Sort Rows
(Automatically Updates when Data Changes)
o If a Rule has been applied, a pink Rules tab will appear at the bottom of the table

Table |Rules

Example: Automate P> Online Library P> Create New Variables P Create Top 2
Category Variables

File > Data Sets P> Update (and replace the datafile)
See: Exporting

¢ R objects in the Report Tree will turn grey if out of date (if the source changes)
 If you want the output to update automatically, tick the Automatic box
o If you want to run your calculation manually, leave the box un-ticked
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Question Type and Variable Type determine how variables will be used in R
calculations:

Prepare the data o For Numeric variables, choose Number, Number — Multi, or Pick Any

o For Factors, choose Pick One or Pick One — Multi

o For Ordered Factors, also change the Variable Type to Ordered Categorical

Create P> R Output

Refer to variables and tables by name to use them in your calculation:

o For variables, check the Name column in the Variables & Questions tab

o For tables, right-click in the Report and select Reference name

Doing Calculations in R

Custom Calculations

You can use R to do custom
calculations, and many
options below also use R.

Standard R Items in the Create menu marked with R use R to run the analysis

« If you want the output to update automatically when the data changes, tick the
Automatic Updating Automatic box
« If you want to run your calculation manually, leave the box un-ticked

Advanced Analyses

All are found under the

Create menu. e Link the analysis up to source data (table, variables), as per the steps in in Interactive

The advanced analyses that and Advanced Visualizations

use R « In the Object Inspector on the right, you can view and edit the R Code. Go to
Properties > R Code

Many advanced analﬁas

use R and show the
symbol. Some advanced
analyses do not use R.

Further documentation, videos and worked examples are available on the wiki at wiki.g-researchsoftware.com as well as the Displayr
Blog at www.displayr.com/blog
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Question Types

The way that Q presents data is determined by the underlying Question Type of the data. Question types are set automatically when
importing data and can be modified in the Variables and Questions tab.

Description Example

a Text Each observation in the data file contains text. What is your name?
4 Text—Mui Multiple related fields of text for each observation in the Please type in the names of your three favorite soft drinks
d data file. 1. 2. 3.
Pick One A set of mutually exclusive and exhaustive categories Are you...
(i.e., nominal or ordinal scales). O Male O Female
Please rate your satisfaction with the following airlines:
Pick One— A series of Pick One guestions sharing the same scale ) Low Med High
Multi points. United a | O
British Airways O [m| [m|
Qantas [m| [m| [m|
. . o . How many glasses of wine did you drink last night?
23 Number A numeric variable (i.e., interval or ratio scale).
glasses
. . . Next to the brands below, please indicate how many times you have
2 Num_ber - A series of numeric variables measured on the same purchased them in the past week
2 Multi scale. .
Coke _ Pepsi___ Fanta__
- What is usually referred to in market research as a Which of the following have you bought in the past week?
m Pick Any multiple response or multi question. Respondents are Cok Pepsi Fant
- asked to pick all that apply from a list of options. 0 Coke O Pepsi O Fanta
= Pick Any — Same as Pick Any but stored in a more compact format Same as Pick Any but stored in a more compact format (see the Q
[  Compact (see the Q Reference Manual). Reference Manual).
Which of these brands are cool?
O Coke @O Pepsi O Fanta
p _ A set of binary variables that can be thought of as being . >
== (lercls Any ordered in two dimensions (e.g., a Pick Any question \ghc':cgkgf th;sg:ri?dsmafaﬁ:ng.
- asked in a loop). p
Which of these brands are sexy?
0O Coke [ Pepsi 0O Fanta
_ - _ In the past month, how many economy flights did you take on...
A question requiring numeric responses, where the .
2 2 Number — variables can be thought of as being ordered in two Qantas ___ United ___ Delta ___
22 Grid Ichme)nsnons (e.g., a Number — Multi question asked in a ...and how many business class flights did you take on...
oop).
Qantas ____ United ___ Delta
- ) o What is your date of birth?
3] Date A question containing a date.
. 119
3 Multiple numeric variables that represent a ranking, where  Rank the following brands according to how much you like them...
137 Ranking the highest number is most preferred and ties are Cok P Fant
permitted. oke_ Pepsi_  Fanta__
Which of these would you buy?
A Number, Number — Multi, Ranking, Pick One or Pick .
X Experiment  One — Multi question, where the alternatives presented Coke Pepsi Fanta
were varied using an experimental design. $2.00 $4.20 $3.20
Can Bottle Flask
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