Q Cheat Sheets

What to do when you
cannot figure out how to
use Q

Right-click on whatever it is you are trying to change

Type into Search

Search features and data

Get help interpreting a table

Help P> Interpret This Table

Read the wiki

Help P Q Wiki (Online Reference Manual)

Do some training modules

Help P Online Training

Contact support

support@g-researchsoftware.com

What to do when the data
looks wrong

Contact the person that set up the project (if you did not do it yourself)

Check the base

base n = 0; total n = 13; 13 missing; 88% filtered out;

Check n and base n

Statistics — Cells P n or Base n

Check statistical testing

Show significance: Compare columns -

Edit P> Project/Table Options P> Statistical Assumptions

Check that the Question Type setting
makes sense on the Variables and
Questions tab

Either go to the Variables and Questions tab and find the data, or, press '#
to the right of the relevant dropdown menu

Check that the Filter is correct

Eg Filter: Q8. One or more message not recalled

Check that the Weight is appropriate

Eg. Weight: None

Check that the correct rules are applied
and, try and remove the rules

Table |Rules

If a Rule has been applied, a pink Rules tab will appear
at the bottom of the table. Control when applied using
the Apply dropdowns

Hide or unhide variables

On the Variables and Questions tab, press

Check if empty rows/columns are are
hidden

Check to see if @ is depressed (this hides empty rows and columns)

Review the Value Attributes

Right-click on a row or column heading and select Values

Review how a variable has been
constructed

1. Go to the Variables and Questions tab
2. Find the variable
3. Right-click: Edit Variable

Contact support

File » Send Pack P To Support and indicate which table and which cells in
the table look wrong and why

Data files and file
management

When you analyze data in Q
you are always using two files:

e Project file (. Q): this
contains all the work you
have donein Q.

e Datafile (e.g.,.sav): this
contains your survey data;
Qdoes not change the
raw data.

Start a new project

. File » Import New Data File (New Project)

. Either click Yes to all questions, or, use a special-purpose QScript for
cleaning

. Automate P Brows Online Library » Preliminary Project Setup

N

Starting using a QPack

3

1. Double-click on the QPack or File B Open Existing Project
2. File » Save Project

3. Read any messages carefully (as you may destroy work)

Opening a project

File P Open Existing Project or Recent Projects

Share projects

File P Send Pack This sends the project and data files

Update project with new data

File » Import Updated Data File (Current Project)

Merge different projects

Open two copies of Q and drag and drop tables and variables from one project
to another

Merge data files

Tools P Merge Data Files

Stack data

Tools P Stack SPSS Data File

Panel data (e.g., occasion-based data)

1. Stack the data (if necessary)
2. File » Add Data to Project
3. File > Edit Data File Relationships

Weights and filters

Weights and filters can be
applied to the entire project or
to selected tables and plots.

Applying filters and weights

Filter: {ia &3] AND [Total sample[v| ¥ weight: None v

Creating a weight

Create P Variables and Questions P> Variable(s) P Weight

Allowing variables to be selectable as
weights and filters

On the Variables and Questions tab, press F| W/

Creating simple filters

Automate P> Browse Online Library B Create Filters from Selected Data

Creating filters from a table

Create a table, select the relevant cells and press v

Creating complicated filters

Find filters created from a table on the Variables and Questions tab (V&Q),
right-click: Edit variable
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Tables and plots

Note that the one of the main
ways of modifying a table is to
change the data in the table,
and when this is done all other
tables using the same data will
also change (see Manipulating
Data)

View additional statistics

Right-click: Statistics — Cells/Right/Below »

Duplicate a table

Changing the data

Country © |SUMMARY v

Create plots in Q

Select from Show Data As (top middle of the screen)

Customizing the look and feel of tables

File P Project Options and Table Styles

Lock the dropdowns used to select data
on a table

Right-click on table(s) in the Report and select Lock

Create folders

Right-click on a table in the Report and Add group

Create lots of tables

Automate P> Browse Online Library P Create Tables P> Banner Tables (this
also automatically creates banners and flattens data — see Manipulating Data)

Simultaneously change lots of
tables/plots

Select them all at the same time and then modify as normal (e.qg., apply filters,
right-click and Statistics — Cells

Viewing raw data

Seeing the raw data for a question

Brown dropdown menu: RAW DATA

Seeing raw data for lots of variables in
Excel

1. Select the variables in the Variables and Questions tab
2. Right-click: Export variables to Excel

3.In Excel: VIEW P Freeze Panes P Freeze Top Row
4.In Excel: DATA P Filter

Seeing all the raw data in Q

All the raw data is viewable on the Data tab. You can sort columns, show filters
and re-order the columns (this is done on the Variable and Questions tab)

Exporting

Any chart templates that you
create in Excel, PowerPoint
and Word, are available in the
Format dropdown that
appears when exporting. See
also Viewing raw data.

Export to PDF

File P Export to PDF

Create online report

File P Share as Dashboard

Export to Excel, PowerPoint and Word

] (2] (w]

Automatically update Office exports

] (2] (w]

Setting default chart types for Office

1. Create Chart Templates using Excel, Word or PowerPoint
2. Edit P> User Options P> Export Chart Defaults

Manipulating data

There are lots of tools for
manipulating data. These are
only some of the more
commonly-used basic tools.

Merging

Drag and drop, or, right-click: Merge

Creating NETs

Right-click: Create NET

Reproducing merging and creating
NETs on other similar questions

Automate P Browse Online Library P Modifying Data P> Use a Question as
a Template for Modifying Other Questions

Re-ordering categories/sorting

e Drag and drop
e Right-click: Sort By
o Automate P> Online Library and search for sort

Removing a category and rebasing

e Right-click: Remove (only for mutually exclusive options)
e Filtering: Create a NET and right-click on it: Create filter

Removing a category without rebasing

Right-click: Hide

Switch between % and averages as
main statistics on a table

1. Right-click on the row or column headers of the data on the table
2. Select the question (its name will appear near the bottom)
3. Select Restructure and the appropriate option.

Creating a 2" version of a question

Right-click on table row/column heading: Duplicate Question

Comparing two questions (e.g., pre and
post)

1. Go to the Variables and Questions tab
2. Select the variables in the questions.
3. Right-click: Copy and Paste Variable(s) » Exact copy
4. Select the newly-created copies
5. Right-click: Set Question
6. Choose an appropriate Question Type
a. Pick One — Multi if combining two categorical questions
b. Number — Multi if combing two numeric variables
c. Number — Grid if combing sets of numeric variables
d. Pick Any — Grid if comparing multiple response questions

Banding numeric variables

1. See Creating a 2nd version of a question
2. See Switch between % and averages as main statistics on a table

Recoding (changing Value Attributes)

Right-click on table row/column heading, select Values and change the
numbers in the Value column

Flatten (i.e., change a grid to a single
column)

Automate P> Browse Online Library P> Create New Variables P> Flatten

Create a banner

1. Create a new table
2. Create P> Banner... and then select the banner in the brown drop-down
menu

Nest one variable within the variables
in a Pick One — Multi (i.e., grid)

e Automate P Browse Online Library P Filtering P> Filter One Question by
Another Question, or
o Stack the data: Tools P> Stack SPSS .sav File

Create a numeric variable

Create P> Variables and Questions P> Variable(s) P> JavaScript Formula »
Numeric




Example:ql + g2 * 14 / 3
If statement: == means “equals”, | |
if ((age <= 39 ||

Shorthand if statement
age > 39 2 1 : 2;

Multi-line expression
var respondent age = dl;

var respondent gender = d2;
var age by gender = respondent age + 100

age by gender;

fit == 1)

means “or” ,and && means “and”:
&& gender == 1) 1;

else 2;

* respondent gender;

Create a categorical variable

1. See Create a numeric variable
2. See Switch between % and averages as main statistics on a table

Recoding into a different variable

1. Right-click: Copy and Paste Variable(s) » Exact copy
2. Modify the variable as per your needs

Standard mathematical functions

V&Q: Insert Ready-Made Formula(s) P Mathematical Functions (by Case)

Creating a binary variable

Follow the steps for creating filters Weights and Filters

Automation

Automatically creating variants of a
derived variable

V&Q: Insert Ready-Made Formula(s) P> Use as Template for Replication

Creating a custom QScript

1. Type the name of a similar QScript (') into the Search box
2. Hover your mouse over the QScript in QScripts and Rules.
3. Press Edit a copy

4. Modify as per your needs and save and close it.

5. Automate P> Run QScript (Macro) from file

Creating a custom Rule

Automate > Custom Rule > Edit JavaScript, or, follow the same process as
with Creating a custom QScript, except using a Rule (™).

Automatic dashboard updating

web-g.com/API

Factor analysis / Principal
Components Analysis

Standard Principal Components
Analysis (PCA)

1. Create a single Number - Multi question with all the variables that you wish to
include

2. Create P> Traditional Multivariate Analysis P Principal Components
Analysis

3. Re-run the analysis with different numbers of components (if desired). It can
be useful to delete the components that are created.

Non-linear Principal Components
Analysis

Create » Map P Type of Analysis P Use the questions selected below
(multiple correspondence analysis)

Saving factors from non-linear PCA

Choose Save factors on the dialog box

Brand association analysis

Brand Maps

1. Create a table of the data (e.g., a SUMMARY table of a Pick Any — Grid
question)

Create > Map P Type of Analysis P Use the current table:
Correspondence Analysis

Choose your preferred Plotting option

N

Driver analysis

Stack the data
Use one of the methods described below for Regression

Residual analysis

PiINPIW

Create a table of the data (e.g., a SUMMARY table of a Pick Any — Grid
question)

Statistics — Cells P z-Statistics, which shows normalized residuals (i.e., a
score of more than 1.96 is significantly high at the 0.05 level, ignoring multiple
comparison issues)

N

Max-Diff and Choice
Modeling

Please note that Q does not
currently create experimental
designs, but plan to launch
this capability in 2016

Importing the experimental design into
a project

Automate P> Browse Online Library P Max-Diff B Max-Diff Setup from an
Experimental Design, or, ... Automate P Browse Online Library » Choice
Modeling P> Choice-Based Conjoint (CBC) Setup

Viewing statistics

1. Right-click and select Statistics — Cells
2. Select all the cells on the table (except headings) and press o

Segmentation

Create P> Segments and press OK (see Segmentation)

Coefficients for each respondent

1. Set the Case IDs in the Data tab

2. Create segments, or, another mixture model (Create P Segments »
Advanced)

3. Right-click on a segment and select Save Individual-Level Parameter
Means and Standard Deviations

4. Select RAW DATA in the Brown dropdown menu

Profiling the results

Create crosstabs with the Question created when the experimental design was
imported (i.e., this is vastly superior to using the individual-level coefficients)




Correlation, Regression Correlation

Select Number or Number — Multi questions in the Blue and Brown
dropdowns

and Driver Analysis

Linear Regression

1. Ensure that the Dependent Variable has a Question Type of Number

2. If you are planning to use stepwise regression, ensure that variables that
you wish grouped together are in the same question, and variables that you
want treated separtely are in separate questions

3. Ensure that any numeric independent variables are Number or Number —
Multi and any that you wish to treat as categorical are a categorical
Question Type

4. Create P> Traditional Multivariate Analysis P> Regression

Binary Logit

Same as linear regression, except with a Pick One dependent variable with
two categories

Ordered Logit

Same as linear regression, except with a Pick One dependent variable that
has Variable Type of Ordered Categorical

Multinomial Logistic

Same as linear regression, except with a Pick One dependent variable that
has Variable Type of Categorical

MNL, Rank-Ordered Logit, Latent Class
Logit, Random Parameters Logit

1. Setup the regression as an Experiment (i.e., this is what is done when you
setup a Max-Diff or Choice Modeling experiment)
2. Create P Segments P Advanced

Automating large numbers of
regressions

Setup the regression as an Experiment (i.e., this is what is done when you
setup a Max-Diff or Choice Modeling experiment), and then create tables,
each which will contain regressions

TURF

Automate P> Browse Online Library » Multivariate » TURF...

Shapley regression, Kruskal Driver
Analysis, etc.

Automate P> Browse Online Library P Multivariate P> Driver (Importance)
Analysis

Segmentation

Preparing the data

Create appropriate derived variables (see the earlier section). E.g.,
e Show rating scales as Top 2 Boxes (i.e., Pick Any)

Show rating scales Number — Multi

Show rating scales as Ranking

Automate P> Browse Online Library P> Create New Variables P
Standardize Data by Case

Principal Components Analysis

Create the segments

Create P> Segments

Select the desired questions in Questions to Analyze

. Ensure that Form segments by is set to splitting by individuals (latent
class analysis, cluster analysis, mixture models)

Press Advanced and you have additional options. Note that the defaults in
segmentation are generally pretty useful, but if you modify advanced options
you can quite easily create invalid analyses.

Re-run the analysis with:

Different input variables

Different Question Types for the input variables

Different number of segments (Create » Segments » Number of segments
per split » Manual

wpE e

>

e e O

Profiling the segments

Create P> Smart Tables
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Question Types

The way that Q presents data is determined by the underlying Question Type of the data. Question types are set automatically when

importing data and can be modified in the Variables and Questions tab.

Question Type

Description

Example

A Text Each observation in the data file What is your name?
contains text.
i: Text — Multi Multiple related fields of text for each Please type in the names of your three favorite soft drinks
observation in the data file. 1. 2. 3.
Pick One A set of mutually exclusive and Are you... O Male O Female

exhaustive categories (i.e., nominal or
ordinal scales).

Pick One — Multi

A series of Pick One questions sharing

Please rate your satisfaction with the following banks

the same scale points. Low Med High
Westpac O O O
ANZ O O |
St George O O O
2 Number A numeric variable (i.e., interval or ratio ~ How many glasses of wine did you drink last night? ____
scale).
E Number — Multi A series of numeric variables measured Next to the brands below, please indicate how many times you

on the same scale.

have purchased them in the past week

Coke _ Pepsi___ Fanta ___

E pick Any

What is usually referred to in market
research as a multiple response or multi

question. Respondents are asked to pick

all that apply from a list of options.

Which of the following have you bought in the past week?

0 Coke [ Pepsi [ Fanta

= Pick Any — Compact

Same as Pick Any but stored in a more compact format (see the Q Reference Manual).

EE pick Any - Grid

A set of binary variables that can be
thought of as being ordered in two
dimensions (e.g., a Pick Any question
asked in a loop).

Which of these brands are cool?
0 Coke [ Pepsi [ Fanta

Which of these brands are young?
0 Coke [ Pepsi [ Fanta

Which of these brands are sexy?
0 Coke [ Pepsi O Fanta

j j Number — Grid A question requiring numeric responses,  In the past month, how many economy flights did you take on...
where the variables can be thought of as Qantas United SAS
being ordered in two dimensions (e.g., a . . .
Number — Multi question asked in a ...and how many business class flights did you take on...
loop). Qantas ___ United SAS
Date A question containing a date. What is your date of birth?

—J__J19___

3 Ranking

Multiple numeric variables that
represent a ranking, where the highest
number is most preferred and ties are
permitted.

Rank the following brands according to how much you like them...

Coke Pepsi Fanta

X Experiment

A Number, Number — Multi, Ranking,
Pick One or Pick One — Multi question,
where the alternatives presented were
varied using an experimental design.

Which of these would you buy?

Coke Pepsi Fanta
$2.00 $4.20 $3.20
Can Bottle Flask




